import Foundation
let pattern = #"(?i)(?m)(?:[\w]\:|\\)(\\[a-z_\-\s0-9\.]+)*(?=\\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"C:\Users\Mistura\Desktop\INITEST - Copy2\In\Bershka_555_v4.pdf.txt"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)