use strict;
my $str = 'C:\\Users\\Mistura\\Desktop\\INITEST - Copy2\\In\\Bershka_555_v4.pdf.txt';
my $regex = qr/(?i)(?m)(?:[\w]\:|\\)(\\[a-z_\-\s0-9\.]+)*(?=\\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}