$re = '/(?i)(?m)(?:[\w]\:|\\\\)(\\\\[a-z_\-\s0-9\.]+)*(?=\\\\)/';
$str = 'C:\\Users\\Mistura\\Desktop\\INITEST - Copy2\\In\\Bershka_555_v4.pdf.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);