using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?m)(?:[\w]\:|\\)(\\[a-z_\-\s0-9\.]+)*(?=\\)";
string input = @"C:\Users\Mistura\Desktop\INITEST - Copy2\In\Bershka_555_v4.pdf.txt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}