import Foundation
let pattern = #"^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cengage.prod.SSO/OLR.CMP.commerce.CMP-COMMERCE-PROD-5.5.10.proxy
cengage.stage.aplia.CMP.aplia.stage.proxy
cengage.stage.CMP.CMP.shared.base.proxy
cengage.performance.SSO/OLR.CMP.commerce.CMP-COMMERCE-LOAD-5.5.10.proxy
cengage.performance.Core-Systems.CMP.shared.DT-TESTING.proxy
cengage.stage.MindTap.CMP.mindtap.5.1.17-build.1.1.proxy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)