re = /^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)/m
str = 'cengage.prod.SSO/OLR.CMP.commerce.CMP-COMMERCE-PROD-5.5.10.proxy
cengage.stage.aplia.CMP.aplia.stage.proxy
cengage.stage.CMP.CMP.shared.base.proxy
cengage.performance.SSO/OLR.CMP.commerce.CMP-COMMERCE-LOAD-5.5.10.proxy
cengage.performance.Core-Systems.CMP.shared.DT-TESTING.proxy
cengage.stage.MindTap.CMP.mindtap.5.1.17-build.1.1.proxy
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end