# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)"
test_str = ("cengage.prod.SSO/OLR.CMP.commerce.CMP-COMMERCE-PROD-5.5.10.proxy\n"
"cengage.stage.aplia.CMP.aplia.stage.proxy\n"
"cengage.stage.CMP.CMP.shared.base.proxy\n"
"cengage.performance.SSO/OLR.CMP.commerce.CMP-COMMERCE-LOAD-5.5.10.proxy\n"
"cengage.performance.Core-Systems.CMP.shared.DT-TESTING.proxy\n"
"cengage.stage.MindTap.CMP.mindtap.5.1.17-build.1.1.proxy\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.