import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^.]*.[^.]*.[^.]*.[^.]*.[^.]*.([^.]*+)";
final String string = "cengage.prod.SSO/OLR.CMP.commerce.CMP-COMMERCE-PROD-5.5.10.proxy\n"
+ "cengage.stage.aplia.CMP.aplia.stage.proxy\n"
+ "cengage.stage.CMP.CMP.shared.base.proxy\n"
+ "cengage.performance.SSO/OLR.CMP.commerce.CMP-COMMERCE-LOAD-5.5.10.proxy\n"
+ "cengage.performance.Core-Systems.CMP.shared.DT-TESTING.proxy\n"
+ "cengage.stage.MindTap.CMP.mindtap.5.1.17-build.1.1.proxy\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}