re = /\n-\s*(.*?)\n/m
str = 'word word
- clozed
- content
- content
- word
- word
word wrod
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end