package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n-\s*(.*?)\n`)
var str = `word word
- clozed
- content
- content
- word
- word
word wrod
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}