#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n-\s*(.*?)\n"
Local $sString = "word word" & @CRLF & _
"" & @CRLF & _
"- clozed" & @CRLF & _
" - content" & @CRLF & _
" - content" & @CRLF & _
"- word" & @CRLF & _
"- word" & @CRLF & _
"" & @CRLF & _
"word wrod" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")