$re = '/\n-\s*(.*?)\n/m';
$str = 'word word
- clozed
- content
- content
- word
- word
word wrod
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);