// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/api\/front\/reference\/(.*)(\?+)(.*)").unwrap();
let string = "api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full?_locale=fr_FR
api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}