#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/api\/front\/reference\/(.*)(\?+)(.*)"
Local $sString = "api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full?_locale=fr_FR" & @CRLF & _
"api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")