package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/api\/front\/reference\/(.*)(\?+)(.*)`)
var str = `api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full?_locale=fr_FR
api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}