re = /\/api\/front\/reference\/(.*)(\?+)(.*)/m
str = 'api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full?_locale=fr_FR
api/v1/membership/803f67ee5c2ebee259e0b05c4f0d1c55/informations/full'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end