re = /^(?(?=.*abc$)($^)|(.*))$/m
str = 'asjfhaskjfasf abc
asjfklaslfjkladjfl
jfkldsjflkldsjflsd
fjkldsjlfkjdsljflkds
jkljlkjlkj
abc
jfjfjabckljfkldalfasd
al;akab
ajklfjlkdflkds3jkfpodajfds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end