$re = '/^(?(?=.*abc$)($^)|(.*))$/m';
$str = 'asjfhaskjfasf abc
asjfklaslfjkladjfl
jfkldsjflkldsjflsd
fjkldsjlfkjdsljflkds
jkljlkjlkj
abc
jfjfjabckljfkldalfasd
al;akab
ajklfjlkdflkds3jkfpodajfds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);