#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?(?=.*abc$)($^)|(.*))$"
Local $sString = "asjfhaskjfasf abc" & @CRLF & _
"asjfklaslfjkladjfl" & @CRLF & _
"jfkldsjflkldsjflsd" & @CRLF & _
"fjkldsjlfkjdsljflkds" & @CRLF & _
"jkljlkjlkj" & @CRLF & _
"abc" & @CRLF & _
"jfjfjabckljfkldalfasd" & @CRLF & _
"al;akab" & @CRLF & _
"ajklfjlkdflkds3jkfpodajfds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")