import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?(?=.*abc$)($^)|(.*))$";
final String string = "asjfhaskjfasf abc\n"
+ "asjfklaslfjkladjfl\n"
+ "jfkldsjflkldsjflsd\n"
+ "fjkldsjlfkjdsljflkds\n"
+ "jkljlkjlkj\n"
+ "abc\n"
+ "jfjfjabckljfkldalfasd\n"
+ "al;akab\n"
+ "ajklfjlkdflkds3jkfpodajfds";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}