// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z]*)\s*([\d\/\s\,]*)\s*(.*)$").unwrap();
let string = "17a Taylor Street
13/1 McDougall St
76 Lyndhurst street
PO Box 177
30 Sunbeam Road
Level 24, 17-24 Kippax St";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}