import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]*)\\s*([\\d\\/\\s\\,]*)\\s*(.*)$";
final String string = "17a Taylor Street\n"
+ "13/1 McDougall St\n"
+ "76 Lyndhurst street \n"
+ "PO Box 177\n"
+ "30 Sunbeam Road \n"
+ "Level 24, 17-24 Kippax St";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}