const regex = /^([a-zA-Z]*)\s*([\d\/\s\,]*)\s*(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]*)\\s*([\\d\\\/\\s\\,]*)\\s*(.*)$', 'gm')
const str = `17a Taylor Street
13/1 McDougall St
76 Lyndhurst street
PO Box 177
30 Sunbeam Road
Level 24, 17-24 Kippax St`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}