re = /codez/m
str = '(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/720P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\"\\})
(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/480P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\"\\})
(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/240P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\"\\})'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end