import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "codez";
final String string = "(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/720P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\\"\\})\n\n"
+ "(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/480P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\\"\\})\n\n"
+ "(https\\:\\\\\\/\\\\\\/[a-zA-Z]+\\.phncdn\\.com\\\\\\/videos\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/[0-9]+\\\\\\/240P+\\_[a-zA-Z0-9]+\\_[0-9]+\\.mp4\\?)+[a-zA-Z0-9=& ]+(?=\\\"\\})";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}