#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)codez"
Local $sString = "(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/720P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})" & @CRLF & _
"" & @CRLF & _
"(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/480P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})" & @CRLF & _
"" & @CRLF & _
"(https\:\\\/\\\/[a-zA-Z]+\.phncdn\.com\\\/videos\\\/[0-9]+\\\/[0-9]+\\\/[0-9]+\\\/240P+\_[a-zA-Z0-9]+\_[0-9]+\.mp4\?)+[a-zA-Z0-9=& ]+(?=\"\})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")