# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<branch>(?:(?<prefix>.*)\/)?(?<suffix>(?:(?:(?<issue>[A-Za-z0-9-]*-\d*)-)?(?<slug>.*))))"
test_str = ("JIRA-1234-testing-node\n"
"JIRA-1234\n"
"feature/JIRA-1234-testing-node\n"
"bugfix/JIRA5-1234-testing-node\n"
"feature/jira-1234-testing-node\n"
"bugfix/JIRA-1234-testing-node\n"
"release/JIRA-1234-testing-node\n"
"hotfix/JIRA-1234-testing-node\n"
"TEST-TEST/JIRA-1234-testing-node-test\n"
"TEST-1234/JIRA-1234-testing-node_test\n"
"release/v1.0.1\n"
"release/v1.0.1-alpha\n"
"release/v1.0.1-alpha.0\n"
"release/v1.0.1-alpha,16\n"
"release/1.0.1\n"
"release/alpha\n"
"release/beta\n"
"release/latest\n"
"release/next\n"
"release/experimental\n"
"testing-node\n"
"experimenta\n"
"release-v1.6.1-test\n"
"staging\n"
"master\n"
"develope\n"
"release")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.