using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<branch>(?:(?<prefix>.*)\/)?(?<suffix>(?:(?:(?<issue>[A-Za-z0-9-]*-\d*)-)?(?<slug>.*))))";
string input = @"JIRA-1234-testing-node
JIRA-1234
feature/JIRA-1234-testing-node
bugfix/JIRA5-1234-testing-node
feature/jira-1234-testing-node
bugfix/JIRA-1234-testing-node
release/JIRA-1234-testing-node
hotfix/JIRA-1234-testing-node
TEST-TEST/JIRA-1234-testing-node-test
TEST-1234/JIRA-1234-testing-node_test
release/v1.0.1
release/v1.0.1-alpha
release/v1.0.1-alpha.0
release/v1.0.1-alpha,16
release/1.0.1
release/alpha
release/beta
release/latest
release/next
release/experimental
testing-node
experimenta
release-v1.6.1-test
staging
master
develope
release";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}