import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<branch>(?:(?<prefix>.*)\\/)?(?<suffix>(?:(?:(?<issue>[A-Za-z0-9-]*-\\d*)-)?(?<slug>.*))))";
final String string = "JIRA-1234-testing-node\n"
+ "JIRA-1234\n"
+ "feature/JIRA-1234-testing-node\n"
+ "bugfix/JIRA5-1234-testing-node\n"
+ "feature/jira-1234-testing-node\n"
+ "bugfix/JIRA-1234-testing-node\n"
+ "release/JIRA-1234-testing-node\n"
+ "hotfix/JIRA-1234-testing-node\n"
+ "TEST-TEST/JIRA-1234-testing-node-test\n"
+ "TEST-1234/JIRA-1234-testing-node_test\n"
+ "release/v1.0.1\n"
+ "release/v1.0.1-alpha\n"
+ "release/v1.0.1-alpha.0\n"
+ "release/v1.0.1-alpha,16\n"
+ "release/1.0.1\n"
+ "release/alpha\n"
+ "release/beta\n"
+ "release/latest\n"
+ "release/next\n"
+ "release/experimental\n"
+ "testing-node\n"
+ "experimenta\n"
+ "release-v1.6.1-test\n"
+ "staging\n"
+ "master\n"
+ "develope\n"
+ "release";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}