const regex = new RegExp('^(LTE|RS[A-Z]+)\\s*([^:]+):\\s+(.*?)(?=\\s*$)', 'gm')
const str = `AT!GSTATUS?
!GSTATUS:
Current Time: 54902 Mode: ONLINE
System mode: LTE PS state: Attached
EMM state: Registered Normal Service
RRC state: RRC Connected
IMS reg state: No Srv
PCC:
LTE band: B28
LTE bw: 10 MHz
LTE Rx chan: 9260
LTE Tx chan: 27260
RSSI (dBm): -48.0
RSRP (dBm): -74.5
RSRQ (dB): -12.2
RSSNR (dB): 12
Tx Power (dBm):
LTE Cell ID: 23198257
Physical Cell ID: 307
TAC: 57506
SCC1:
LTE band: B1
LTE bw: 15 MHz
LTE Rx chan: 275
RSSI (dBm): -59.5
RSRP (dBm): -87.5
RSRQ (dB): -9.2
Physical Cell ID: 412
OK`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);