#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(LTE|RS[A-Z]+)\s*([^:]+):\s+(.*?)(?=\s*$)"
Local $sString = "AT!GSTATUS?" & @CRLF & _
"!GSTATUS: " & @CRLF & _
"Current Time: 54902 Mode: ONLINE " & @CRLF & _
"System mode: LTE PS state: Attached " & @CRLF & _
"EMM state: Registered Normal Service " & @CRLF & _
"RRC state: RRC Connected " & @CRLF & _
"IMS reg state: No Srv " & @CRLF & _
"" & @CRLF & _
"PCC: " & @CRLF & _
"LTE band: B28 " & @CRLF & _
"LTE bw: 10 MHz " & @CRLF & _
"LTE Rx chan: 9260" & @CRLF & _
"LTE Tx chan: 27260" & @CRLF & _
"RSSI (dBm): -48.0" & @CRLF & _
"RSRP (dBm): -74.5" & @CRLF & _
"RSRQ (dB): -12.2" & @CRLF & _
"RSSNR (dB): 12" & @CRLF & _
"Tx Power (dBm): " & @CRLF & _
"LTE Cell ID: 23198257" & @CRLF & _
"Physical Cell ID: 307" & @CRLF & _
"TAC: 57506" & @CRLF & _
"" & @CRLF & _
"SCC1: " & @CRLF & _
"LTE band: B1 " & @CRLF & _
"LTE bw: 15 MHz " & @CRLF & _
"LTE Rx chan: 275" & @CRLF & _
"RSSI (dBm): -59.5" & @CRLF & _
"RSRP (dBm): -87.5" & @CRLF & _
"RSRQ (dB): -9.2" & @CRLF & _
"Physical Cell ID: 412" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"OK"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)