re = /(?i)(\/| |^)r *\/ *(?!(superstonk( |$|\/)|gme( |$|\/)|all( |$|\/)))\w*(\?|\/|\.| |$|!)/m
str = 'r/all
r/ALL
r
r/superstonk
R/SUPERSTONK
Word r/superstonk
word r/superstonk word
r/superstonk?
r/superstonk.
r/superstonk!
r/superstonk
r /superstonk
https://www.reddit.com/r/Superstonk?utm_medium=android_app&utm_source=share
r/random
R/RANDOM
Word r/random
word r/random word
r/random?
r/superstonk.
r/random!
r/random
r /random
https://www.reddit.com/r/random?utm_medium=android_app&utm_source=share
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end