use strict;
my $str = 'r/all
r/ALL
r
r/superstonk
R/SUPERSTONK
Word r/superstonk
word r/superstonk word
r/superstonk?
r/superstonk.
r/superstonk!
r/superstonk
r /superstonk
https://www.reddit.com/r/Superstonk?utm_medium=android_app&utm_source=share
r/random
R/RANDOM
Word r/random
word r/random word
r/random?
r/superstonk.
r/random!
r/random
r /random
https://www.reddit.com/r/random?utm_medium=android_app&utm_source=share
';
my $regex = qr/(?i)(\/| |^)r *\/ *(?!(superstonk( |$|\/)|gme( |$|\/)|all( |$|\/)))\w*(\?|\/|\.| |$|!)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}