const regex = new RegExp('(?i)(\\/| |^)r *\\/ *(?!(superstonk( |$|\\/)|gme( |$|\\/)|all( |$|\\/)))\\w*(\\?|\\/|\\.| |$|!)', 'gm')
const str = `r/all
r/ALL
r
r/superstonk
R/SUPERSTONK
Word r/superstonk
word r/superstonk word
r/superstonk?
r/superstonk.
r/superstonk!
r/superstonk
r /superstonk
https://www.reddit.com/r/Superstonk?utm_medium=android_app&utm_source=share
r/random
R/RANDOM
Word r/random
word r/random word
r/random?
r/superstonk.
r/random!
r/random
r /random
https://www.reddit.com/r/random?utm_medium=android_app&utm_source=share
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}