re = /https?:\/\/(www\.)?/i
str = 'https://www.raise.me/s/IsdsN
http://localhost/s/ISdsN
https://staging.raise.me/s/IsdsN
https://raise.me/s/IsdsN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end