$re = '/https?:\/\/(www\.)?/i';
$str = 'https://www.raise.me/s/IsdsN
http://localhost/s/ISdsN
https://staging.raise.me/s/IsdsN
https://raise.me/s/IsdsN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);