#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?:\/\/(www\.)?"
Local $sString = "https://www.raise.me/s/IsdsN" & @CRLF & _
"http://localhost/s/ISdsN" & @CRLF & _
"https://staging.raise.me/s/IsdsN" & @CRLF & _
"https://raise.me/s/IsdsN"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")