// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+\.").unwrap();
let string = "1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
";
let substitution = "1.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}