const regex = /^\d+\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.', 'gm')
const str = `1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
`;
const subst = `1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);