import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\.";
final String string = "1.\n"
+ "2.\n"
+ "3.\n"
+ "4.\n"
+ "5.\n"
+ "6.\n"
+ "7.\n"
+ "8.\n"
+ "9.\n"
+ "10.\n"
+ "11.\n"
+ "12.\n";
final String subst = "1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}