import Foundation
let pattern = #".*(?=loc).*(?=act).*(?=dosar)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<h3 class="asset-title"> <a href="https://www.primariapn.ro/anunturi/-/asset_publisher/d8F7ynMHzZPK/event/id/3700162?redirect=https%3A%2F%2Fwww.primariapn.ro%2Fanunturi%3Fp_p_id%3D101_INSTANCE_d8F7ynMHzZPK%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_mode%3Dview%26p_p_col_id%3Dcolumn-2%26p_p_col_count%3D1"><img alt="" src="/ppn321-theme/images/common/date.png"> Actualizare dosare locuințe</a> </h3>
<div class="asset-content">
<div class="asset-summary">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)