re = /.*(?=loc).*(?=act).*(?=dosar)/mi
str = ' <h3 class="asset-title"> <a href="https://www.primariapn.ro/anunturi/-/asset_publisher/d8F7ynMHzZPK/event/id/3700162?redirect=https%3A%2F%2Fwww.primariapn.ro%2Fanunturi%3Fp_p_id%3D101_INSTANCE_d8F7ynMHzZPK%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_mode%3Dview%26p_p_col_id%3Dcolumn-2%26p_p_col_count%3D1"><img alt="" src="/ppn321-theme/images/common/date.png"> Actualizare dosare locuințe</a> </h3>
<div class="asset-content">
<div class="asset-summary">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end