import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(?=loc).*(?=act).*(?=dosar)";
final String string = " <h3 class=\"asset-title\"> <a href=\"https://www.primariapn.ro/anunturi/-/asset_publisher/d8F7ynMHzZPK/event/id/3700162?redirect=https%3A%2F%2Fwww.primariapn.ro%2Fanunturi%3Fp_p_id%3D101_INSTANCE_d8F7ynMHzZPK%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_mode%3Dview%26p_p_col_id%3Dcolumn-2%26p_p_col_count%3D1\"><img alt=\"\" src=\"/ppn321-theme/images/common/date.png\"> Actualizare dosare locuințe</a> </h3>\n"
+ " <div class=\"asset-content\">\n"
+ " <div class=\"asset-summary\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}