re = /(Anhk\.Portal)(?!\.)([a-zA-Z]\w*)/m
str = 'Anhk.PortalApplicationSharedModule
IocManager.RegisterAssemblyByConvention(typeof(Anhk.PortalApplicationModule).GetAssembly());
LocalizationSourceName = Anhk.PortalConsts.LocalizationSourceName;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end