using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Anhk\.Portal)(?!\.)([a-zA-Z]\w*)";
string input = @"Anhk.PortalApplicationSharedModule
IocManager.RegisterAssemblyByConvention(typeof(Anhk.PortalApplicationModule).GetAssembly());
LocalizationSourceName = Anhk.PortalConsts.LocalizationSourceName;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}