$re = '/(Anhk\.Portal)(?!\.)([a-zA-Z]\w*)/m';
$str = 'Anhk.PortalApplicationSharedModule
IocManager.RegisterAssemblyByConvention(typeof(Anhk.PortalApplicationModule).GetAssembly());
LocalizationSourceName = Anhk.PortalConsts.LocalizationSourceName;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);