import Foundation
let pattern = #"\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2015-09-18 07:41:10.878357
2015-09-18T07:41:10.878357
2015/09/18T07:41:10.878357
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)