$re = '/\d{4}(.\d{2}){2}(\s|T)(\d{2}.){2}\d{2}/';
$str = '2015-09-18 07:41:10.878357
2015-09-18T07:41:10.878357
2015/09/18T07:41:10.878357';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;