$re = '/,(?![^\[\]]*(?:\([^[]]]*\])?\])|,(?![^\{\}]*(?:\([^\{\}]]*\})?\})|\{|\}/';
$str = '{[d1].[m1], [d1].[m2]} , {[d1,mw],[d2].[d2,m2]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);