const regex = new RegExp(',(?![^\\[\\]]*(?:\\([^[]]]*\\])?\\])|,(?![^\\{\\}]*(?:\\([^\\{\\}]]*\\})?\\})|\\{|\\}', 'g')
const str = `{[d1].[m1], [d1].[m2]} , {[d1,mw],[d2].[d2,m2]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}